BEFORE YOU BEGIN

 

1. CareerLeader has been written to run on Internet Explorer 7 and 8, as well as the two most recent versions of Safari (4.0 and 5.0) and Firefox (3.6 and 4.0). If you are running earlier versions of these browser software programs, you will need to update your software.

 

2. Before you begin using CareerLeader, please check your browser security settings. CareerLeader was written to run on browsers for Macs and PCs with javascript enabled. If your settings are restrictive, and do not allow javascript to run, you will need to modify them for the program to function as intended.

 

3. CareerLeader should be accessed through either a laptop or desktop computer, not tablets or other mobile technology.

 

4. If you have already attempted to login to CareerLeader prior to adjusting your browser settings, you will need to clear your cache/cookies/history after adjusting the settings before you begin the login process again.

SIGN IN





To return to the previous page, please click